using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^<>&/\[\]\x00-\x20=]++)";
string input = @"This is a test [example attr1=""test1"" attr2=""test2""]content
over multiple
lines with a random [shortcode] inside[/example]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}