import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\/]{2,2})(www\\.[\\w-.]*?[\\w-]+?(\\/[\\w-]*?)*?)(([^\\w.\\/-]+?)|$)+";
final String string = "<p><a href=\"https://www.w3schools.com/html/\"><a href=\"http://www.w3schools.com/html/\">www.w3schools.com</a></p>\n"
+ "<p><a href=\"https://www.google.com/html/\"><a href=\"http://www.google.com/html/\">www.google.com</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}