const regex = /message:\s(?<METADATA_ERROR>[^\\\n]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('message:\\s(?<METADATA_ERROR>[^\\\\\\n]+)', 'gm')
const str = `message: org.springframework.jdbc.UncategorizedSQLException: CallableStatementCallback; uncategorized SQLException for SQL <{call XYZ_API.PROCESS_EVENT(?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)}>; SQL state <16000>; error code <20011>; ORA-00060: deadlock detected while waiting for resource\\nORA-06512: at "ABC_OWNER.XYZ_API", line 5133\\nORA-06512: at "ABC_OWNER.XYZ_API", line 2001\\nORA-06512: at "ABC_OWNER.XYZ_API", line 6829\\nORA-06512: at line 1\\n; nested exception is java.sql.SQLException: ORA-00060: deadlock detected while waiting for resource\\nORA-06512: at "ABC_OWNER.XYZ_API", line 5133\\nORA-06512: at "ABC_OWNER.XYZ_API", line 2001\\nORA-06512: at "ABC_OWNER.XYZ_API", line 6829\\nORA-06512: at line 1\\n'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}