// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ {4}").unwrap();
let string = " try (EchoClient echoClient = EchoClient.create()) {
EchoRequest request = EchoRequest.newBuilder().build();
EchoResponse response = echoClient.echo(request);
}";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}