$re = '/(.)\1{2}/m';
$str = 'Can you ppplease help me fix thhhis?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);