package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)IDNUMBER: (\d\d\d-\w\w)`)
var str = `Ties de Kok (IDNUMBER: 123-AZ). Rest of Text.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}