const regex = /^(\p{L}+?\s)(\p{L}+?\s).*(,.*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\p{L}+?\\s)(\\p{L}+?\\s).*(,.*$)', 'g')
const str = `Jose Jose Romulo Ricardo, lopez de montana.`;
const subst = `\1\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);