Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
((?<func>latest|diff|avg|median|total|rollingmedian|rollingavg)\((?<par>[^(),]*),(?<uom>[^(),]*)(?:,(?<sp>[^()]*|))?\))|((?<func1>diffdays)\((?<par1>[^(),]*)(?:,(?<sp1>[^()]*|))?\))+
/
g
Input 1
1
New
rollingmedian( ecoli, orgs/100mL, [tat10, tat11] ) + latest(ecoli,) + diffdays(ecoli)