package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)X.*`)
var str = `A-B-1_u
A-B-2_u
A-B-3_u
A-B-4_u
A-B-5_u
X-Y1
X-Y1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}