import re
regex = re.compile(r"X.*", flags=re.MULTILINE)
test_str = ("A-B-1_u\n"
"A-B-2_u\n"
"A-B-3_u\n"
"A-B-4_u\n"
"A-B-5_u\n"
"X-Y1\n"
"X-Y1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")