// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)X.*").unwrap();
let string = "A-B-1_u
A-B-2_u
A-B-3_u
A-B-4_u
A-B-5_u
X-Y1
X-Y1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}