package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)^[^\s]*[a-z][^\s][.{1}][^\s\b]*[a-z][^.\b][^\s\b]$`)
var str = `test.com
www.alexan.com
wander.economical.badnc.edu.org
https://website.com
wad.
wanders
WAD.ness
ww w.edu catio n.net`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}