re = /<(\w+\:[\w.-]+)>/m
str = '<staticText:HelloWorld>_<xmlNode:Node.03>_<date:2011-12-12>_<time:23-59-11-222>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end