#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(transfer|rent)\D+(\d+(?:[,.]\d+)*)"
Local $sString = "19 Aug standing order rent Apolo Housing Assoc. 500.00 50.00" & @CRLF & _
"20 Aug transfer from John wick saving a/c 200.00 130.90"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")