package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d\.\d+\s+ZQ\s+(\S+(?:\s\S+)*)`)
var str = `DE1ALAT0002 32.4756 -86.4393 106.1 ZQ DISNAY LAND 2.0 GCP 23456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}