#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z][a-zA-Z=0-9;]*"
Local $sString = "3. 宿舍开水一壶价格已达到1元以上,%给学生用水造成很大负担。" & @CRLF & _
"4. 空调租赁机制不合理问题,%租赁只能以年为单位,但学生一般只在夏季使用,多出费用很多" & @CRLF & _
"5. 厕所洗手液没有%及时更换" & @CRLF & _
"matlab=123;%this is a matlab test function" & @CRLF & _
"Matlab=123;%this is a matlab test function"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")