const regex = new RegExp('^[a-zA-Z][a-zA-Z=0-9;]*', 'gm')
const str = `3. 宿舍开水一壶价格已达到1元以上,%给学生用水造成很大负担。
4. 空调租赁机制不合理问题,%租赁只能以年为单位,但学生一般只在夏季使用,多出费用很多
5. 厕所洗手液没有%及时更换
matlab=123;%this is a matlab test function
Matlab=123;%this is a matlab test function`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}