import Foundation
let pattern = #"^[a-zA-Z][a-zA-Z=0-9;]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3. 宿舍开水一壶价格已达到1元以上,%给学生用水造成很大负担。
4. 空调租赁机制不合理问题,%租赁只能以年为单位,但学生一般只在夏季使用,多出费用很多
5. 厕所洗手液没有%及时更换
matlab=123;%this is a matlab test function
Matlab=123;%this is a matlab test function
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)