using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\n\r]*?PVD-666432[^\n\r]*+\n?";
string substitution = @"";
string input = @"abc PVD-666432def
abc PVD-666432 def
abcPVD-666432
abcd efg
PVD-666432abc
ab cd ef
PVD-666432 abc";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}