use strict;
my $str = 'abc PVD-666432def
abc PVD-666432 def
abcPVD-666432
abcd efg
PVD-666432abc
ab cd ef
PVD-666432 abc';
my $regex = qr/^[^\n\r]*?PVD-666432[^\n\r]*+\n?/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";