import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^(?:(?:\\d+:(?:\\s00)*\\n)*)(?:\\d+:(?:\\s00)*)\\s+)\\b(?!00)[0-9-afA-F]{2}\\b";
final String string = "0000: 00 00 00\n"
+ "0001: 00 f8 00\n"
+ "0002: 11 00 22\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}