use strict;
my $str = 'import { Inject, Injectable } from "../core/decorators";
@Injectable()
class A {
public run() {
console.log(\'This is A\');
}
}
class B {
@Inject(\'A\') private a!: A;
@Logger() class: number = 22;
public constructor() {
this.a.run();
}
}
new B();
console.log(B.toString());
';
my $regex = qr/(?<={|;)\s*@([\w_\$]*)\s*(\([\s'"\w_\$,#]*\))?\s*((public|private|protected)?\s+([\w_\$]*)\s*!?\s*:?\s*\w*\s*=?\s*([\w()\$]*))(?=}|;)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}