package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<[^>\r\n]*>`)
var str = `<some chars and special chars maybe !@#$% but not gt and new lines and of course bounded by gt st>
<some chars and special chars maybe !@#$% but not gt and new lines
and of course bounded by gt st>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}