import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>\\r\\n]*>";
final String string = "<some chars and special chars maybe !@#$% but not gt and new lines and of course bounded by gt st>\n\n"
+ "<some chars and special chars maybe !@#$% but not gt and new lines \n\n"
+ "and of course bounded by gt st>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}