import Foundation
let pattern = #"_ABC(?:(?!_ABC).)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
_AB:C-_ABCDEF_ABC:45_ABC:454:
_AB:C-_ABCDEF_ABC:45_ABC_ABC:454:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_CBA"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)