using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!\bbag\b).)*\bred\b.+?\bbag\b";
string input = @"choose balls if they are in red bag, or they are in green bag
choose balls if they are in green bag, or they are in red bag
choose balls if they are in red bag
choose balls if they are in green bag
bag red bag
red bag red
green bag red bag
red bags";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}