import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!\\bbag\\b).)*\\bred\\b.+?\\bbag\\b";
final String string = "choose balls if they are in red bag, or they are in green bag\n"
+ "choose balls if they are in green bag, or they are in red bag\n"
+ "choose balls if they are in red bag\n"
+ "choose balls if they are in green bag\n"
+ "bag red bag\n"
+ "red bag red\n"
+ "green bag red bag\n"
+ "red bags";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}