import re
regex = re.compile(r"^(?:(?!\bbag\b).)*\bred\b.+?\bbag\b", flags=re.MULTILINE)
test_str = ("choose balls if they are in red bag, or they are in green bag\n"
"choose balls if they are in green bag, or they are in red bag\n"
"choose balls if they are in red bag\n"
"choose balls if they are in green bag\n"
"bag red bag\n"
"red bag red\n"
"green bag red bag\n"
"red bags")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")