re = /^(?:(?!\bbag\b).)*\bred\b.+?\bbag\b/m
str = 'choose balls if they are in red bag, or they are in green bag
choose balls if they are in green bag, or they are in red bag
choose balls if they are in red bag
choose balls if they are in green bag
bag red bag
red bag red
green bag red bag
red bags'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end