package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#(\w+)\.(\w+)`)
var str = `endpoint/?userId=#someuser.id
Hi #someuser.name, how are you?
# .id, #.id. `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}