$re = '/(\s+)?(.+?)(\s+)?(years?|months?).*/m';
$str = ' Eight years blah blah 50 blah blah, two years blah blah blah.
Eight years blah blah 50 blah blah, two years blah blah blah.
Eight months blah blah 50 blah blah, two years blah blah blah.
One month blah blah 50 blah blah, two years blah blah blah.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);