import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<type>[a-zA-Z2]*)(\\((?<precision>\\d*)(,(?<scale>\\d*))?\\))?";
final String string = "varchar(30)\n"
+ "timestamp\n"
+ "number(20,5)\n"
+ "NUMBER(20,3)\n"
+ "timestamp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}