const regex = new RegExp('(?<type>[a-zA-Z2]*)(\\((?<precision>\\d*)(,(?<scale>\\d*))?\\))?', 'gms')
const str = `varchar(30)
timestamp
number(20,5)
NUMBER(20,3)
timestamp`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}