const regex = /^(?:origin\/develop|origin\/master|origin\/release\/\d+\.\d+\.\d+(?!.)|origin\/release\/\d+\.\d+\.\d+(?:_uat|_preprod))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:origin\\\/develop|origin\\\/master|origin\\\/release\\\/\\d+\\.\\d+\\.\\d+(?!.)|origin\\\/release\\\/\\d+\\.\\d+\\.\\d+(?:_uat|_preprod))$', 'gm')
const str = `origin/release/0.0.0_uat
origin/master
feature
origin/feature/0.0.0
origin/develop
dev
origin/release/0.0.0
origin/release
origin/release/0_0_0
origin/release/0/0/0
origin/release/0.0.0_preprod
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}