re = /(?:^|\t)
(
[^\t\n]+(?=(?:\t|\n[^ ]))
|
[^\t\n]+(?=(?:\t|\n([ ]+)))
)
#(|[ ]{20})#(?![ ]{3,})
#|
#[^\t]+?(?=(?:\n)([ ]+)")
/xm
str = 'База Базовая добыча (вЯк 8) 42370
Бурение well_obj1_1_prod (вЯк 8) 42370
Бурение well_obj1_1_inj (вЯк 8) 42430
"'
subst = '/$2/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result