#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d*\.\d*|\d*|x_{\d*}|\(.*?\)+)[\/]+(\(.*?\)|x_{\d*}|\d*\.\d*|\d*)"
Local $sString = "311/3-31.2/3+x_{3}/4+(3+4)/2+(x_{12}/2+234)/1+9/(3+8)+(5+9/8)/5.6+x_{8}/x_{7}+(3)/m"
Local $sSubst = "\\frac{$1}{$2}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)