$re = '/^(?:[^|]*\|){6}\K[^|]*/m';
$str = 'XL231241424|AB|ABCDE|LK|Word|A Phrase|Another random phrase|GH49|Example|31/02/2020|05/03/2020|N/A|N/A|N/A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);