using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+_build_block_\(chapter_\d+\)\.xml$";
string input = @"1_build_block_(book).xml
2_build_block_(chapter_1).xml
3_build_block_(chapter_2).xml";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}