const regex = /^\d+_build_block_\(chapter_\d+\)\.xml$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+_build_block_\\(chapter_\\d+\\)\\.xml$', 'gm')
const str = `1_build_block_(book).xml
2_build_block_(chapter_1).xml
3_build_block_(chapter_2).xml`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}