$re = '/\?v(?:er)?\b/';
$str = ' "?ver" and "?v", but not the word "?version"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);