# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"event_sub_type\":\"((WAN\s+Firewall)|TLS)"
test_str = ("1. event_sub_type\":\"WAN\n\n"
" \n\n"
"{\"event_count\":1,\"ISP_name\":\"Shanghai internet\",\"rule\":\"Initial Connectivity Rule\",\"dest_is_site_or_vpn\":\"Site\",\"src_isp_ip\":\"0.0.0.0\",\"time_str\":\"2023-11-28T04:27:40Z\",\"src_site\":\"CHINA-AZURE-E2\",\"src_ip\":\"0.0.0.1\",\"internalId\":\"54464646\",\"dest_site_name\":\"china_112,\"event_type\":\"Security\",\"src_country_code\":\"CN\",\"action\":\"Monitor\",\"subnet_name\":\"cn-001.net-vnet-1\",\"pop_name\":\"Shanghai_1\",\"dest_port\":443,\"dest_site\":\"china_connect\",\"rule_name\":\"Initial Connectivity Rule\",\"event_sub_type\":\"WAN Firewall\",\"insertionDate\":1701188916690,\"ip_protocol\":\"TCP\",\"rule_id\":\"101238\",\"src_is_site_or_vpn\":\"Site\",\"account_id\":5555,\"application\":\"HTTP(S)\",\"src_site_name\":\"china_connect\",\"src_country\":\"China\",\"dest_ip\":\"0.0.0.0\",\"os_type\":\"OS_ANDROID\",\"app_stack\"\"TCP\",\"TLS\",\"HTTP(S)\"],\"time\":1701188860834}\n\n"
" \n\n"
"2. \"event_sub_type\":\"TLS\",\"\n\n"
" \n\n"
"{\"event_count\":4,\"http_host_name\":\"isp.vpn\",\"ISP_name\":\"China_internet\",\"src_isp_ip\":\"0.0.0.0\",\"tls_version\":\"TLSv1.3\",\"time_str\":\"2023-11-28T04:27:16Z\",\"src_site\":\"china_mtt\",\"src_ip\":\"0.0.0.0\",\"internalId\":\"rtrgrtr\",\"domain_name\":\"china.gh.com\",\"event_type\":\"Security\",\"src_country_code\":\"CN\",\"tls_error_description\":\"unknown CA\",\"action\":\"Alert\",\"subnet_name\":\"0.0.0.0/24\",\"pop_name\":\"china_1\",\"dest_port\":443,\"event_sub_type\":\"TLS\",\"insertionDate\":1701188915580,\"dest_country_code\":\"SG\",\"tls_error_type\":\"fatal\",\"dns_name\":\"china.com\",\"traffic_direction\":\"OUTBOUND\",\"src_is_site_or_vpn\":\"Site\",\"account_id\":56565,\"application\":\"Netskope\",\"src_site_name\":\"CHINA-44\",\"src_country\":\"China\",\"dest_ip\":\"0.0.0.0\",\"os_type\":\"OS_WINDOWS\",\"time\":1701188836011,\"dest_country\":\"Singapore\"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.