import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^>]*A(?=<)";
final String string = "<table class=\"prod-fit-info-table\">\n"
+ " <tbody>\n"
+ " <tr class=\"tr -dark-grey\">\n"
+ " <th class=\"td -outer\">Make</th>\n"
+ " <th class=\"td -outer\">Model</th>\n"
+ " <th class=\"td -outer\">Year</th>\n"
+ " </tr>\n"
+ " <tr class=\"tr -first\">\n"
+ " <td class=\"td\" rowspan=\"1\">Make A</td>\n"
+ " <td class=\"td\">Model A</td>\n"
+ " <td class=\"td\">Year A</td>\n"
+ " </tr>\n"
+ " <tr class=\"tr -grey -first\">\n"
+ " <td class=\"td\" rowspan=\"1\">Make B</td>\n"
+ " <td class=\"td\">Model B</td>\n"
+ " <td class=\"td\">Year B</td>\n"
+ " </tr>\n"
+ " <tr class=\"tr -first\">\n"
+ " <td class=\"td\" rowspan=\"1\">Make C</td>\n"
+ " <td class=\"td\">Model C</td>\n"
+ " <td class=\"td\">Year C</td>\n"
+ " </tr>\n"
+ "</tbody>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}