package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+[\u00A0]*`)
var str = `1000 kr`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}