#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\h{3}-\h(\S)"
Local $sString = "- Right? Yeah? - Yeah." & @CRLF & _
"" & @CRLF & _
"- What's your name? - I'm... I'm Caleb." & @CRLF & _
"" & @CRLF & _
"- I'm Christina. - Beatrice."
Local $sSubst = " - $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)