using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Phone:\s*(\d[-\d]+)";
string input = @"more text
Phone: 123-567-345 more text
more text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}