import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*([^.]+(?=\\([\\w ,.]+(, *\\?)?(\\d{4}|\\d{2})\\)\\.?))(\\([\\w ,.]+(, *\\?)?(\\d{4}|\\d{2})\\)\\.?)";
final String string = "\"Nothing is here. In this line, actually, there is a citation (Author et al., 2022). Once again, In this line there is nothing.\"\n"
+ "Other lines with parenthesis (but they do not match because of missing year).\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}