#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^abc]*"
Local $sString = "abcdebcfghijk" & @CRLF & _
"" & @CRLF & _
"^は状況により意味が変わる" & @CRLF & _
"[]内にある時は~以外という意味になる" & @CRLF & _
"" & @CRLF & _
"通常は行の先頭を表す" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")