using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^abc]*";
string input = @"abcdebcfghijk
^は状況により意味が変わる
[]内にある時は~以外という意味になる
通常は行の先頭を表す
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}