Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
[^abc]*
/
gm
Input 1
1
New
abcdebcfghijk ^は状況により意味が変わる []内にある時は~以外という意味になる 通常は行の先頭を表す