import re
regex = re.compile(r"[^abc]*", flags=re.MULTILINE)
test_str = ("abcdebcfghijk\n\n"
"^は状況により意味が変わる\n"
"[]内にある時は~以外という意味になる\n\n"
"通常は行の先頭を表す\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")